Break-fix test / Hackers needed

By 2015-10-02 Buffalo + Plex

Hello Hackers,

I’ve recompiled both versions of transmission for the Buffalo v1.71 libraries. This means it’s not supposed to SEGFAULT on the firmware anymore. I haven’t packaged it yet because I need testers to confirm that the issue is resolved. (I still can’t reproduce it.)

This is some advanced testing so if you are not sure of your linux skills please stay tuned for the packaged version soon.

Prerequisites:

  • You need to be able to use wget or scp or WinSCP to copy the files to your Buffalo. You will need basic Linux knowledge to understand what’s happening.
  • Have the “Andimaginary” version of the firmware installed.
  • Open SSH on port 2222 on your Buffalo Linkstation.

Setup steps:

  • Log on to your Buffalo Linkstation with SSH on port 2222 (stay in the /root folder)
  • Download the recompiled transmission binaries using wget:


/usr/bin/wget --no-check-certificate https://raw.githubusercontent.com/GaryTomato/buffaloplex/master/firmwares/transmission-2.77.tgz
/usr/bin/wget --no-check-certificate https://raw.githubusercontent.com/GaryTomato/buffaloplex/master/firmwares/transmission-2.84.tgz

  • (As an alternative you can download the links with your favorite browser and copy it onto the Linkstation using scp in Linux or WinSCP in Windows. Put them in /root. )
  • Remove the old transmission binaries


rm -r /usr/local/transmission/latest/bin
rm -r /usr/local/transmission/latest/share
rm -r /usr/local/transmission/stable/bin
rm -r /usr/local/transmission/stable/share

  • Unzip the new versions


tar -xvzf transmission-2.77.tgz -C /usr/local/transmission/stable
tar -xvzf transmission-2.84.tgz -C /usr/local/transmission/latest

  • Restart transmission from the web interface or using


/etc/init.d/transmission.sh stop
/etc/init.d/transmission.sh start

There you have it. Check your web interface and please send me feedback if the new transmission binaries fixed the issue. If not, we’ll have to revert back to older versions of the Buffalo firmware which I’d rather not do for security reasons.

 

So, what’s new?

These binaries were rebuilt with the exact same dependent libraries that are installed on the v1.71 version of the Buffalo firmware. Namely it is now built with OpenSSL 0.9.8ze. The older firmwares (v1.69) were built with OpenSSL 0.9.8v and I suspect that the issue is that I built transmission with that in the previous release. Zlib is also reverted to v1.2.3 and libcurl to v7.19.6 which are quite old versions but I wanted to make sure transmission uses the exact same libraries that the firmware has.

I hope this helps, please send feedback as soon as possible so I can get a new release together.

– GaryT

4 Comments

  • mapuo says:

    The new builds didn’t work for me 🙁
    As soon as I add a torrent file and the transmission crashes.
    /var/log/messages:
    Oct 2 21:47:00 storage4t transmission: WaitBtDie is finished.
    Oct 2 21:47:02 storage4t transmission: Folder setting is changed.
    Oct 2 21:47:03 storage4t transmission: WaitBtDie is finished.

  • exe says:

    Hello.
    The same for me. Once I add torrent file new stable binary crashes.
    /var/log/messages last entry;
    transmission: WaitBtDie is finished.

    • garyt says:

      Hi exe,

      We’re working on it with Mapuo. Which Buffalo Linkstation do you have?

      – GaryT

  • exe says:

    Hello.
    I’ve got LS-VL but I suppose it doesn’t matter in this case. It’s kernel/libraries/binary issue.
    I’m afraid I will not be able to provide you any feedback anymore, since I’ve switched system into Debian Jessie.
    (no issues at all reg. transmission-daemon).

Leave a Reply